56 lines
1.1 KiB
RPMSpec
56 lines
1.1 KiB
RPMSpec
# Generated by rust2rpm 26
|
|
%bcond_without check
|
|
|
|
# prevent library files from being installed
|
|
%global cargo_install_lib 0
|
|
|
|
%global crate SolutionTM
|
|
|
|
Name: SolutionTM
|
|
Version: 0.1.0
|
|
Release: %autorelease
|
|
Summary: Simple demonstration of the Iced GUI library
|
|
|
|
SourceLicense: MIT
|
|
# FIXME: paste output of %%cargo_license_summary here
|
|
License: MIT
|
|
# LICENSE.dependencies contains a full license breakdown
|
|
|
|
URL: no
|
|
Source: %{crate}-%{version}.tar.gz
|
|
Source: %{crate}-%{version}-vendor.tar.gz
|
|
|
|
BuildRequires: cargo-rpm-macros >= 26
|
|
BuildRequires: cargo >= 1.78
|
|
|
|
%global _description %{expand:
|
|
A simple demonstration of the Iced GUI library.}
|
|
|
|
%description %{_description}
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version} -p1 -a1
|
|
%cargo_prep -v vendor
|
|
|
|
%build
|
|
%cargo_build
|
|
%{cargo_license_summary}
|
|
%{cargo_license} > LICENSE.dependencies
|
|
%{cargo_vendor_manifest}
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%files
|
|
%license LICENCE.txt
|
|
%license LICENSE.dependencies
|
|
%license cargo-vendor.txt
|
|
%{_bindir}/SolutionTM
|
|
|
|
%changelog
|
|
%autochangelog
|